Previous 1 2 3 4 5 6 Next 4,659 Replies Latest reply: Oct 29, 2014 11:58 PM by jasonb b Go to original post Branched to a new discussion.
  • UserB Level 1 (0 points)

    I was having a similar problem all day. Belkin N750 router, problem on both 2.4GHz and 5GHz bands.  The iPhone 5 would connect (with security enabled on the router), but no data was flowing.  Occasionally I'd get brief data movement and then it would die.  Then after connecting and re-connecting a lot it all of the sudden works and things 'seem' stable.  Getting a solid 23-24 Mbps now with the app which I've run about a dozen times over the past two hours without problems.  Of course at this point who knows if it will last.

  • deandorsey Level 1 (0 points)

    2 iphone 5's neither will connect to my wireless router - "unable to join the network" error message on both. 


    my 2 iphone 4's are connected as is my laptop.  this is extremely disappointing.


    i have tried EVERYTHING in this thread and other to no avail, i am at a loss. 

  • Joe Win Level 1 (0 points)

    Just noticed a problem of range with my new iPhone 5, received by delivery from The Apple Store earlier today. I live in a small 410 sq.ft. apartment. My iMac and my Apple Base Station are in my bedroom, at one end of the apartment. Starting with my iPhone 3, to the iPhone 4, to the new iPad, I’ve had no problem ever having a full signal when I go sit in my living room at almost the farthest possible end of my apartment from where the base station is located, perhaps 40 feet away. I’ve surfed the web, checked email, even used the Time Warner app to watch TV stations from that position without problem. I’ve even gotten the signal from my Wifi setup through the walls and out to where I catch the elevator, about 100 feet away. And this is not the latest Apple Base Station, but one removed. And, yes, I use passworld security on my network. I believe it’s WPA2.


    About an hour ago, I realized that my iPhone 5 was on LTE when I was sitting in my living room, in the same spot where I’ve never had an Wifi signal issue before. Checked the Wifi setting and it didn’t see my network. I went into the bedroom and picked up my iPhone 4 and brought it out to that spot, and it had a completely full Wifi signal. The iPhone 5 was on LTE.


    I then went back into the bedroom with both phones and started walking towards the spot in the living room. Less than halfway there, the Wifi signal on the 5 starts dropping. By the time I got just over halfway there, approximately 20 feet from the Base Station, the Wifi signal was gone; full signal on the iPhone 4. I then went to the living room spot, again the 5 had no Wifi while the 4 had a full signal, and started walking back towards the bedroom. When I got just about halfway there, the 5 started registereing my Wifi network.


    I shut off the 5, then powered it up again to see if that made a difference. Nope. Same issue.


    This is not an iOS 6 issue because I’d already upgraded my iPhone 4 to the new OS and it had no issues with Wifi in the 2 days since I upgraded; same reach and same signal strengths for me.


    This is an iPhone 5 issue. On none of my previous iPhone or iPad purchases have I had to run through any hoops to get my usual full Wifi signal. I shouldn’t have to do a restore or a start from scratch re-set-up of my phone. I’m about to call Apple about this, though I’m not sure there’ll be anyone there to help at this hour.

  • C4RLOCO Level 1 (45 points)

    All right everyone. Here are some progress that I made towards finding a pattern.


    My iPhone5 will not browse the web neither in 2.4Ghz nor 5Ghz band with "WPA2 Personal" enabled as security. I can perfectly connect internally but Safari (or any other program) will not connect to the Internet. I cannot even open the router config page ( on these bands.


    Now, I have a Cisco E2500 router capable of opening a "Guest" network with a passcode. My iPhone5 works very well when connected to this Guest network (which of course does not used WPA2). I can browse the web with no issues at all.


    Can anyone out there confirm this with your iPhone5??? Now the real question here is if this is a software or hardware problem. I am still planning to have my phone replaced tomorrow since I read people in this forums confirming that their iPhone5 are working without wifi issues.

  • macvol88 Level 1 (5 points)

    I restored my iPhone 5 with the following ipsw:,2_6.0_10A 405_Restore.ipsw


    That's the latest released build of iOS 6 for the iPhone 5 (CDMA) that I've found. I'm experiencing the exact same issues you are (no data on WPA/WPA2 protected WiFi networks). Unfortunately, the issue still exists. It's starting to look like a hardware issue. That is unless they are using multiple vendors of WiFi cards for the iPhone 5. That's the only thing that could explain why some iPhone 5s work on protected WiFi and some don't.

  • jhager Level 1 (0 points)

    If you have an Apple Time Capsule or Airport be sure to upgrade to the latest firmware (Launch Airport Utility).  This solved my issue and I still have enabled my secure network. 


    More info on this other thread:


  • macvol88 Level 1 (5 points)

    You guys might want to check your cellular data usage. What little data comes over my "flaky" protected WiFi network appears to transparently come from LTE. See my post here:


  • scapla Level 1 (0 points)

    I think this is definitely related to WPA/WPA2.  My connection speed was less than 3 Mbps on my iPhone 5, and 20+ on my 4 and on my laptop.  I turned security off on my router and the speed on the 5 shot up to 20+.  I then switched to 128 bit WEP and am continuing to get 20+ Mbps.  Hopefully Apple issues a fix soon, but at least there's a workaround.


    I don't know if it matters, but I have a Belkin N600.

  • dulinor Level 1 (0 points)

    Same issue - no data from secured WiFi networks (work - WPA2 Enterprise or home WPA2 Personal - Apple Time Capsule, latest firmware/hardware.) Drop security and it works fine.

  • iBryan85 Level 1 (0 points)

    So here is my network setup. Cable modem -> latest gen Time Capsule(latest firmware). Running strictly N mode on both bands. All devices are on the 5GHz band. When running a continuous ping against my iPad, or my wife's iPhone 5, I get 0% packet loss. However, the same ping test ran at the same time to my iPhone 5, I get roughly 80% packet loss every time. I have tried both bands, and it doesnt make a difference. Guess I will be contacting Apple to get my phone replaced. This is insane! I haven't even had the phone for 24 hours yet.


    Check out this thread for more people having the same issue.


    OT: The worst part is my wife complaining that I am "playing with the internet" again, lol. If Netflix goes down...

  • Hamtonio Level 1 (0 points)

    Tried switching to WEP and that did the trick. iPhone 5 doesn't seem to like wpa2 security on routers. Internet on phone works fine now. They need to fix this issue

  • iBryan85 Level 1 (0 points)

    Argh, my Time Capsule doesnt have an option to switch to WEP.

  • scapla Level 1 (0 points)

    Bryan, can you turn security off to see I'd that helps?

  • Dr.$mart Level 1 (0 points)

    I'm having the same issue I just got my iPhone 5 from AT&T this morning. it conects to the WiFi, but the data flows like very slowly.

  • iBryan85 Level 1 (0 points)

    Yes, it did! I changed the name of my guest network and completely left it unsecured. All is right in the world again. Definitely looks like a WPA issue. Now if Apple can get off their rear and patch this, that would be great. This problem should have never made it this far.

Previous 1 2 3 4 5 6 Next