Previous 1 2 3 Next 32 Replies Latest reply: Feb 1, 2016 1:44 AM by adam_d
galindenba Level 1 (0 points)

My latest gen Apple TV will not update it's software. It seems to download the update just fine and then goes to the "preparing update" screen. The progress bar on that screen gets about 90% of the way then I get an "update not successful" message. I have already restarted the device twice as well as unplugged it from the power supply twice and reconnected it before trying the update again. No effect.


Apple TV
  • Munas Level 4 (1,260 points)

    try to update your Apple TV via LAN (Ethernet cable) not the WiFi.

  • galindenba Level 1 (0 points)

    Thanks for your suggestion. Unfortunately, This Apple TV is connected to the network via an Ethernet cable.

  • JoDonBobSpot Level 1 (0 points)

    galindenba wrote:


    Thanks for your suggestion. Unfortunately, This Apple TV is connected to the network via an Ethernet cable.


    I have been having the same problem. Connected on Gigabit network.

    Have tried on several different days at different times. It seems to be updating with the progress bar progressing but it eventually comes back with a message that the install was unsuccessful.


    After reading about how people are having problems after latest Itunes update perhaps Apple has shutdown the file share where the update is located until they can debug it.


    Message was edited by: JoDonBobSpot

  • digitalcyclist Level 1 (5 points)

    Ditto here.  Tried the update several times over a few days (also spanning my update to PC iTunes), both gigabit wired as well as wireless, with a Settings > General > Reset before each attempt.  No go - always fails with "Update unsuccessful".


    I'm going to wait until someone posts here that Apple's got it fixed and the updates are working, before I try again.

  • mmarx82 Level 1 (0 points)

    I have the 3rd gen Apple TV, my update method was over a wired ethernet connection.


    After trying this over and over again for several hours tonight I finally got it to go past preparing update at 90% like you guys were getting. I'm not sure what the issue is but this is what I did so good luck to you guys.


    1. Go to Settings>General>Reset>Reset All Settings

    2. You will have to re-enter your Language settings etc,. (I also had to disconnect my ethernet cord to go past the activation screen, plug it back in afterwords if you do.)

    3. Go to Settings>General>Reset>Restore


    On step 3 I noticed that after awhile it would stop sending a signal to my TV, Initially I would hit a button on the remote to make the progress show back up on the TV(everytime I did I failed at 90% preparing update). The last time I did it, (Which was when it worked) I didn't press any buttons on the remote and after a few minutes of it being a black screen the TV reveived a signal again and it was then applying the update.So you guys can try to let the display stay black for awhile or with no signal and see what happens for you. Report back if it works for you so others know too.

  • galindenba Level 1 (0 points)

    Thanks. I'm glad your solution worked, but I'd rather not have to go through all that. It sounds like this upgrade has some real issues. Hopefully, Apple will resolve this and the upgrade will proceed in the usual way.

  • digitalcyclist Level 1 (5 points)

    I disconnected my wired connection, let the AppleTV run in wireless mode, and the update installed itself without problems.  Then switched back to wired.

  • Level 1 (45 points)
  • Odinsdad Level 1 (0 points)

    I got the new ATV3 firmware (5.1.1) to work... Interested?


    First off, I have both a Apple TV2 (M1378) and a Apple TV3 (M1427). The Apple TV2 updated just fine, The Apple TV3 I tried everything mentioned above, resetting, reloading etc... I even tried connecting the Apple TV3 directly to my Mac Mini (late 2012-10.8.2) via a USB to Micro USB cable (You do have one of those hanging around don't you?) When I follwed the Apple Tech Note # HT4367


    When I click on restore it says it can't find the Apple TV.



    Here's how I got it to work:


    Get a copy of the latest and greatest firmware for the Apple TV3. As I write this it's 5.1.1(ATV3 Version, yes it has a different version than the ATV2 so make sure you get the right one!)


    I found the firmware here:



 ,1_5.1.1_10A83 1_Restore.ipsw

 ,1_5.1.1_10A83 1_Restore.ipsw


    Now that you have downloaded the new firmware onto your local Mac you follow the exact same procedure listed in HT4367 except hold the "Control" key down while pressing the reload key. This will allow you to select a firmware file that you'd like to load, in this case, the one you just down loaded.


    The file will load, verify and reboot.


    Verify the new firmware by selecting settings:about in your Apple TV.


    I hope this helps the next guy as it was quite frustrating making this work. Hopefully Apple will do a better job testing the update process in the future to help avoid this hassle for the "rest of us"...:-)




    Message was edited by: Odinsdad

  • iphoneloser Level 1 (5 points)

    Tried several times using Ethernet, then found this thread and tried WiFi and it worked perfectly.

  • mrmiffee Level 1 (10 points)

    Losing Ethernet and going wifi worked for me, so worth a try

  • galindenba Level 1 (0 points)

    That worked for me as well. Thanks.

  • Toochief Level 1 (0 points)

    That works for me also.

  • digibob7575 Level 1 (0 points)

    Wifi worked for me as well.

Previous 1 2 3 Next