Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone pictures don't load in Photos

Hello everyone


I recently downloaded iOS9 on my iPhone and El Capitan on my iMac. Ever since I'm encountering a problem when trying to import the pictures from my iPhone onto my iMac.


At first, sometimes they would still load in iPhoto/Photos, sometimes they wouldn't. Now they just don't.

iTunes recognizes my iPhone and syncs with it. iPhoto/Photos also recognize my iPhone, but the page in the apps remains blank. The photos won't load and thus I can't import them.


Could anyone help me on how to fix this?


Thank you!


Gregory from Belgium

iPhone 5, OS X El Capitan (10.11)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Do you have non-Apple services running that sync your photos to the cloud automatically? Ie, do you have Dropbox running? If so try disabling it, reboot and reconnect your device to the mac and retry Photos and Image Capture. This worked for me (iOS9.1 and OSX10.11.1). If this works for you go back and reenable Dropbox and tweak the setting so it isn't your default importer.

Posted on

Page content loaded

Oct 26, 2015 9:07 AM in response to gregoryfrombelgium In response to gregoryfrombelgium

Did you confirm on the iPhone that you trust the computer? I had to do it after every software update on the iPhone.

Launch iTunes, connect the iPhone, unlock it. You should be seeing a prompt on the iPhone, if you trust the Mac. Confirm it.

Oct 26, 2015 9:07 AM

Reply Helpful

Oct 27, 2015 12:06 PM in response to léonie In response to léonie

"MacOS X 10.11.1 is supposed to have fixed this"


"Did you confirm on the iPhone that you trust the computer?"


Nope, still not working. Only see photos if I restart the iPhone with it connected with the USB cable. Disconnect USB and reconnect or restart Photos app on Mac and there's nothing showing.


'Trust this computer' never shows again once you've accepted it initially.


I love all my Mac gear but surely someone in Infinite Loop is seeing this as well! Updates to iPhone and Mac last week and this is still an issue doh!

Oct 27, 2015 12:06 PM

Reply Helpful

Oct 27, 2015 12:33 PM in response to Simon201 In response to Simon201

QUOTE "Yep exactly the same for me except if I restart the phone with it connected to my Mac the camera roll photos show and I can import. But if I then disconnect the phone or close photos the next time nothing. Have to restart the phone again. A workaround for me but very annoying. I believe its something to do with the 'trust this computer' thing but I'm not sure how one would really make it show that dialogue box again to be able to click 'trust' (without wiping the phone or something...."


This workaround it's ok for me

Oct 27, 2015 12:33 PM

Reply Helpful

Oct 27, 2015 3:24 PM in response to léonie In response to léonie

Personally, I have never seen any 'trust' at all (wouldn't even know where to agree/disagree with that), but then: it's only a 4S that I have, nothing more sophisticated. I am running the latest iOS (and OSX on my iMac), but again: trust???

Oct 27, 2015 3:24 PM

Reply Helpful
Question marked as Helpful

Oct 28, 2015 11:19 PM in response to lescornwell In response to lescornwell

Well after a little Googling and experimentation, I've found a few things.


First of all creating a temporary new user on my iMac shows none of these issues. Camera roll shows every time I start the photos app or plug in my iPhone.


So anyhow back to my main login.


This page gives the instructions to reset the 'Trust this computer' Reset the Lockdown folder in iTunes - Apple Support. Did all that, hit 'Trust this computer' etc and yes after plugging in my phone or starting the photos app, the cameral roll showed. But it was slightly short-lived. After unplugging my phone and re-plugging in I was back to no photos showing.


I seem to have, accidentally or whatever discovered a new workaround that at the moment seems to work every time. I have the computer set so the Photos app opens when I connect my phone, and if I connect, my camera roll doesn't show. So this is my procedure. (I had actually done the reset Lockdown folder a few times as well)


1. Close 'Photos' app (on Mac)

2. Open iPhoto - Camera roll still not showing.

3. Leave iPhoto open but disconnect and reconnect iPhone.

4. Camera roll then all shows in iPhoto. ('Photos' app opens on reconnection but still no camera roll)

5. With iPhoto open (or closed), if I go to the Photos and refresh the import tab the Camera roll all appears yay!


Still a nuisance but at least I can get it to work. TBH I believe this issue is something to with either the migration from a previous Mac OS and/or with the migration from iPhoto to Photos.

Oct 28, 2015 11:19 PM

Reply Helpful (4)
Question marked as Solved

Oct 28, 2015 11:20 PM in response to gregoryfrombelgium In response to gregoryfrombelgium

Do you have non-Apple services running that sync your photos to the cloud automatically? Ie, do you have Dropbox running? If so try disabling it, reboot and reconnect your device to the mac and retry Photos and Image Capture. This worked for me (iOS9.1 and OSX10.11.1). If this works for you go back and reenable Dropbox and tweak the setting so it isn't your default importer.

Oct 28, 2015 11:20 PM

Reply Helpful (7)

Nov 5, 2015 9:28 PM in response to Clem In response to Clem

Clem,


that looks promising. How do see and control which service is the "default importer". In Dropbox I just see a checkbox to enable/disable import. I don't know of any place to control which is the default. In the past, I have had both iPhoto and Dropbox importing photos. With Photos, that detente seems unstable.

Nov 5, 2015 9:28 PM

Reply Helpful
User profile for user: gregoryfrombelgium

Question: iPhone pictures don't load in Photos