Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone X and ImageCaptureCore error -9937 import error

Hi - I've been having this issue since upgrading to iPhone X last year. In a nutshell, all I am trying to do is use image capture to get the jpg/mov/png files from my phone to a local directory on my Mac so I can backup my files to the external HD. Photos app has no issues importing and happens within minutes however when I use image capture I get the following error popup


The operation couldn’t be completed. (com.apple.ImageCaptureCore error -9937.) (-9937).

An error occurred while importing. The item “IMG_0861” was not imported.

This seems to be happening on the mov files only, which I'm recording on the iPhone X as 4K at 30fps. The above file mentioned on the error message was 1.38GB. I've tried to reach out to phone support for Mac and iPhone as well as the genius bar and no one can tell me why it takes more than 24 hours of my phone being plugged into Mac and I still can't get all my videos out via image capture. I've tried importing one at a time for 1gb or more and I get thrown the above error. Its disappointing to see apple offering 4k recording but you cannot get the file imported.


thoughts on this?

Posted on

Reply

Feb 28, 2018 12:32 PM in response to yolie09 In response to yolie09

How much memory do you have left on your iPhone? there's a possibility that it doesn't have enough memory to import it. I'm not really sure why this happens, but I think it might be changing the format of the video and then sending it to the computer. This is just a guess though.

Feb 28, 2018 12:32 PM

Reply Helpful

Apr 2, 2018 6:36 AM in response to yolie09 In response to yolie09

Only recently began having this problem on iPhone X. Discovered the problem after 11.3 and 10.13.4 upgrade, but suspect it's not related. It's not just movies for me: I can't import anything in Photos. Have 200GB of storage (not "RAM") free. Image Capture works to import the photos.


I've found this is related to iOS - Setting for Photos - Transfer to Mac/PC. When set to Keep Originals and pics are HEIF I can't import. Setting to Automatic allows me to import the photo, but in JPEG when it should be in native HEIF.


Also, I see there are JPEG versions of every HEIF image that I edit. That's not how it used to work and it sure doesn't save space like HEIF is supposed to.


I remember having a problem importing photos on a previous iPhone. That problem was caused by a corrupted photo. Once I found and removed the photo, imports worked fine. That doesn't seem to be related to my current problem. YMMV.

Apr 2, 2018 6:36 AM

Reply Helpful (4)
User profile for user: yolie09

Question: iPhone X and ImageCaptureCore error -9937 import error