Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Incorrect device name in Photos 3.0 (not iTunes)

When pulling photos and movies from multiple devices (lets call them A, and B) into Photos library, the sidebar devices-list does not shows incorrect phone (Photos shows device A while B is actually plugged in) and therefore cannot pull photos (on occasion notifies that i must unlock the 'incorrect' phone).


In iTunes, I am able to see both devices (and after i renamed the devices A to A' and B to B', then iTunes shows correct device list (via wifi connection). Now that I have renamed devices, iPhoto still shows A even if A', or B' is connected via Cable. iPhoto device does visually/audibly drop connection (disconnect) when cable removed.


Reboot devices, and restart iTunes /Photos to no avail.


All software appears to be up to date.

iMac (21.5-inch, Mid 2014)

MacOS HighSierra 10.13.4

Photos 3.0 / iTunes 12.7.4

Iphone X iPhone 6+ iOS 11.3 (both)

(Library on External 5T drive)

iMac, macOS High Sierra (10.13.4), Photos 3.0

Posted on

Reply

Page content loaded

Apr 20, 2018 2:21 PM in response to Ybotman In response to Ybotman

Ah - good test - Finder does not show.


So, when i connect cable, i do hear the 'power' ping, and if iTunes is present the properly named devices shows up.


So with or without iTunes, no device in finder.

Apr 20, 2018 2:21 PM

Reply Helpful

Apr 21, 2018 9:41 AM in response to Ybotman In response to Ybotman

After the evening (Not a reboot) - the devices are showing correctly. I am able to operate normally. Curious i do not understand why. Thanks for the response. But still no iPhone in finder-devices. Not sure i have ever seen this.


Interestingly, this not the first time I have noticed (but only the first time i tried to drill down) on the problem. Have seen this problem 3x before, but only after a return after a day or so does it resolve. Any ideas? Memory has been an issue (and subsequent long periods of 'lockout') when pulling v large slowmo movies. Plenty of available space on local and extra drives

Apr 21, 2018 9:41 AM

Reply Helpful
User profile for user: Ybotman

Question: Incorrect device name in Photos 3.0 (not iTunes)