Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Enable messages in iCloud option not visible on Mac

I have an iMac and updated to 10.13.5 yesterday but in the Messages app, the option to 'enable messages in iCloud' in not visible.


'About this Mac' is definitely saying version 10.13.5 and when I go to software updates it says 'none available' and I can see that Mac OS High Sierra 10.13.5 Update was installed on 1 June.


But when I go into the Messages app -> Preferences -> Accounts, there is only the option to 'enable this account' (like there was in previous versions of MacOS). There is no option to enable messages in iCloud.


Has anyone any idea what is going on here and what I need to do to fix it?


Thanks.

iMac, OS X El Capitan (10.11.6)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Some people in another thread were able to resolve this problem by checking the “Keychain” checkbox in their iCloud system preference. Try that and see if it works!

Posted on

Jun 2, 2018 8:39 AM in response to Jack presley In response to Jack presley

Make sure you have taken all 7 of these steps:


1. You must have two-factor authentication turned on for your iCloud account at https://appleid.apple.com/


2. Upgrade all of your iOS devices to iOS 11.4, then enable "Messages" in the Settings > Your Name > iCloud. (Launch Messages on your iOS devices and you will see a progress bar at the bottom of your messages list. This will take several hours -- maybe longer.)


3. Now go to your Mac, and upgrade it to macOS High Sierra 10.13.5.


4. On your Mac, make sure that the exact same iCloud account is signed in at "System Preferences > iCloud".


5. Launch the Messages app on your Mac.


6. In "Messages > Preferences > Accounts", choose your iCloud account on the left, and then check the checkbox that says "Enable Messages in iCloud" on the right. Then, click on the "Sync Now" button. (Then, you will need to wait several hours -- maybe longer -- for the sync to finish. You will see a progress bar at the bottom of your messages list.)


7. If you want all of your Messages that you delete on your Mac to also be deleted on your iOS 11.4 devices, then you ALSO must take an additional step that Apple didn't inform anybody about. Go to "Messages > Preferences > General", and UNCHECK the checkbox that says "Save history when conversations are closed".

Jun 2, 2018 8:39 AM

Reply Helpful (1)

Jun 2, 2018 9:22 AM in response to Jack presley In response to Jack presley

Enable Messages in iCloud" is absent in 10.13.5.

Followed all steps and option to enable is not on screen

iPhone and iPad upgraded to 11.4 and turned on Messages in Settings

Upgraded Mac to 10.13.5 then opened Messages and clicked on Accounts in Preferences and there is no option to enable Messages in iCloud?

Jun 2, 2018 9:22 AM

Reply Helpful (1)

Jun 2, 2018 9:27 AM in response to pcnewton In response to pcnewton

Do you have two-factor authentication turned on for your iCloud account?


Once you click on Accounts in Preferences, did you click on your iCloud account in the left margin? The checkmark should show up on the right.


If not, you may try downloading & installing the macOS High Sierra 10.13.5 Combo Update from Apple. This installer is a more thorough way of updating macOS, and might help in some cases.

Jun 2, 2018 9:27 AM

Reply Helpful

Jun 2, 2018 11:33 AM in response to Scott Rose In response to Scott Rose

This fixed it for me as well. I have two Macs, one was working one wasn't. The one that wasn't didn't have keychain syncing enabled in iCloud preferences. Once enabled the option to save messages in iCloud was available.


Can you update your first post to reflect this since several people have resolved their issue this way and your post is the first that pops up when trying to resolve this issue?


Thank you!

Jun 2, 2018 11:33 AM

Reply Helpful (1)

Jun 6, 2018 8:55 AM in response to Scott Rose In response to Scott Rose

I do not believe that you are correct in your point 7.


"Save history when conversations are closed" relates to 'closing' a conversation. Not to 'deleting' it.


Closing = clicking the x

Deleting = swipe left / Delete


The difference is that when you 'close' a conversation it just does that, closes it. But it is still there as an unopened conversation. When it is re-opened, it will reappear, in its entirety *if* you have this option selected.


I don't think iOS offers this possibility.

Jun 6, 2018 8:55 AM

Reply Helpful

Jun 6, 2018 9:22 AM in response to Scott Rose In response to Scott Rose

To be honest Scott, I've never even considered there could be a difference, until configuring Messages in iCloud and I agree that it is probably the behaviour that most people would want/assume to be the case.


However ... the two are not synonymous and are actually separate behaviours. It does though, explain to me why I have in the past closed a conversation (thinking I was deleting it) and then when a new conversation is started with the same person ... all of the previous conversation is still there ... because it wasn't deleted, it was closed!

Jun 6, 2018 9:22 AM

Reply Helpful
User profile for user: Jack presley

Question: Enable messages in iCloud option not visible on Mac