Previous 1 2 3 Next 40 Replies Latest reply: Dec 20, 2013 11:34 AM by ThrustinJ
schoolofluck Level 1 (20 points)

Most schools are hurting because configurator 1.4 is mostly broken.(Sept 2013)



Here is what helps, take action


  • reply to this thread with new bugs and documentation
  • call enterprise support   create a case ID # (866) 752-7753 
  • review the list of bugs on this thread
  • give the Apple CEO feedback URL



Known bugs in version 1.4 of configurator


1)  Setup screens keep reappearing & Wifi fails on ipad after using configurator to make any change to ipad. Possible workaround is to disconntect from USB and slide to power off. 


2) Volume App codes being lost. Paid apps changed to free apps.  No known workaround. Not fully verified.


3) Check in & check out fails -


4) IT staff can't lockout iOS updates, but can lockout App updates.  - This renders  Configurator 1.3 and 1.21 dead.   Configurator v1.21 and 1.3 do not support iOS7, and most schools have had iOS7 installed because it arrives at the whim of any one student or ipad user.

iPad 2, iOS 5.1.1
  • AndyBeaver Level 1 (15 points)

    I have a few work arounds.



    2)  Remove the apps from AC by selecting the app and clicking the "-" button. Then re-add the apps. In testing i have seen this occur when apps are updated through itunes and imported back into AC.


    4) We were able to prevent our students from installing iOS 7 by blocking through DNS and our web filter this address. ( A little late now but...)






    hope this helps, its been a rough week for us all!

  • schoolofluck Level 1 (20 points)

    Thanks Andy for the iOS7 block!    I've been asking Apple support staff for a fix or workaround for 13 months. Our weeks of suffering this year mirror last year with ios 5-6 and configurator v1.1 


    The ios7 block means we can get some stablility back this year.  We plan to wait 2 months for ios7.  


    goes to show that good support comes from many sources. 

  • Surreyschools_Teacher Level 1 (5 points)

    Other issues I have been having include (v.1.4, iOS 7.02)


    - Setup screens still appearing even after backup file is applied to device

    - Restore file not applying at all or producing errors on refresh

    - Have lost the supervision certficate a couple of times, but I could still unsupervise the device and recover VPP codes.


    The problem of the restore file not being applied is a big one for me as I can't configure the layout accurately and replicated a configured iPad.  Has anyone else been seeing this problem?  I called our local Apple SE and they have seen this too.  Any workarounds?

  • fpcs2 Level 1 (0 points)

    I updated to Apple Configurator (AC) 1.4, but now I cannot install a new textbook reader app on iPads that were updated to iOS 7.0 by our students.  Keep in mind that these iPads were originally supervised with AC 1.3, all apps are installed via AC, I manage a total of 2,150 iPads, 900 at the school where I found this issue.  (Luckily, at this time this issue only applies to 60 of those!)  The steps I have taken are:

    1. Several student iPads crashed to the Connect to iTunes screen when I tried to install a new app via AC 1.3.  I thought this was strange, so I asked and found out these students had updated to iOS 7. I could not find proof of anything else that caused this, so I figured it was a bug with iOS 7 and AC 1.3, took a chance and updated to AC 1.4.
    2. Restored these iPads, re-supervised them in AC 1.4 and tried to apply a backup of a 6.1.3 “master”iPad.  The backup failed.  I understand that problem is probably a 6.1.3/7.0 compatibility issue, so I did not restore any backups.  Apps appear to be installing without any problems.  (Now, that I read these posts, I need to double check the VPP apps.)
    3. Next, I tried to install the textbook reader app on iOS 7 devices that had not crashed to the Connect to iTunes screen.
    4. The “Unable to check iOS” error appeared.
    5. Turned off Find my iPad.
    6. Tried to install the app again by clicking Refresh and less than a second later AC chimes to confirm the update is complete.  However, nothing happens.  The app is checked, but it never installs on any of the iPads.  (I’ve tried multiple iPads at the same time and individually.)
    7. I tried to remove an existing AC profile by un-checking it, but the same thing happens.

    Anyone else seeing this?

  • Surreyschools_Teacher Level 1 (5 points)

    I see this same behaviour as you describe in #6, refreshes that take less that a second to complete - only nothing installs and for me not that includes a backup profile.


    I did try one thing that seemed to force things, set AC to refresh automatically in the preferences. For me that would force the restore profile to install, but still other weird things would happen like selected apps not refreshing properly.

  • tphy Level 1 (0 points)

    I have seen #1, #4, and #6 in fpcs2's post. I also get an error "fetch list of apps" and "device disconnected" when it is still connected. When I try to refresh a device with AC 1.4, sometimes I get the "device disconnected" error or it will do the refresh, then symbol that indicates battery/charging in the upper-right of the device will display "Not Charging."


    I'm afraid to touch my iPads with 6.1.3 to the AC or iTunes because they essentially break the iPad and force the iOS 7 update on me. I can't apply apps to the iPads and I'm frustrated.


    Thanks for listening, and I will be patient bear and keep watching this thread.

  • fpcs2 Level 1 (0 points)

    The only solution I have found is to turn off Find My iPad, unsupervise, re-supervise and apply backup, reinstall apps.  (You will receive the cannot check OS error if you did not turn off Find My iPad.  Also, the backup I'm installing now is new and made with a 7.0.2 iPad.)

  • nsdjoey Level 3 (925 points)

    The DNS block is something we did on Day 1 of iOS 7 and it has worked well for us keeping everyone on iOS 6. I wish there was a configuration profile that would enable iOS Admins to restrict iOS updates...but at least the DNS block is an effective workaround.


    Hope all of these iOS 7 bugs get resolved soon! There are a lot of great things that iOS 7 offers that I want to take advantage of, but won't until things are a bit more stable. Keeping fingers crossed for prompt bug fixes...



  • schoolofluck Level 1 (20 points)

    Reports are in that profiles for 3rd party apps being deleted.  In this case the app is "meraki". 



    It seems there is no way to restore an ipad back to ios6 and old configurator once the ipad has tasted ios version 7.


    Please correct me if I am wrong.  I have one ipad that updated to ios7 and it can no longer be managed by our stable version of configurator.  That's version 1.21 which works great with ios6. 

  • nsdjoey Level 3 (925 points)

    Hey schoolofluck,


    Yeah, unfortunately Apple has stopped signing all versions of iOS 6 for iPad. So even with a complete wipe of an iOS 7 iPad in an attempt to restore an old iOS 6 encrypted backup, a restore via iTunes will force the device to check in with Apple and the latest version of iOS 7 will install on the iPad. I've also tried importing an old ipsw file for 6.1.3 into iTunes and into Apple Configurator to try and force loading iOS 6.1.3, but niether iTunes or Apple Configurator will install it.



  • SPH_Heart Level 1 (5 points)

    Ditto with the profiles getting deleted even though I have unselected "delete profiles and apps not installed by configurator"


    My post is here:


  • Dan Autiero Level 1 (0 points)

    Here is the major flaw that I found. I can't find out how to download the previous versiuon either so I am pretty screwed at the moment.


  • MrMeansMTA Level 1 (0 points)

    I am seeing that exact same thing.. We don't even use VPP Apps! SO FRUSTRATING!

  • schoolofluck Level 1 (20 points)

    Hi Dan A.   - You are correct.  Apple is much more restrictive now that OSX uses the "app store" for distribution of software like configurator.     The only choice apple offers is what they consider to be the current version. 


    What's the only fix to updates that have more bugs than the "old" version?


    Answer: Constatnly use an external time machine backup drive.  I had to use this last week.  OSX update included an iTunes update.  iTunes then broke configurator.  I booted my mac from a 10.6 DVD, then did a full restore from a week prior. 


    Here is the summary:  Don't un-supervise  a device that has ios6, because it's then forced to move up to 7.   Once an ipad moves to 7 it can't be managed if your configurator is not current.    If you use the "current" configurator you bump into a new set of bugs.   You can't easily move from the current configurator to the previous configurator.  If you do use time machine to restore the previous configurator, the cart of ipads can't include ios7.


    The recursion is nutty, and the path has bugs no matter what part of the mobeius strip you are on.

Previous 1 2 3 Next